Page 1 of 1

Worcester Greenstar Heatslave 12/18 no power to control box no reset power

Posted: Sat Jul 06, 2019 10:08 am
by Iceman5972
No powerto the Control box. Had an oil leak and tried to bleed pump but it appears there is no power to the pump from the control box. There is no red reset light nor, it appears, power to it. I have check the fuse in the pcb. Should there be a supply in the control box wiring seat. See photos.i have tried to suck through oil form the outside tank and the tiger loop is all fine. I think the problem is the control box (Bentone dko 970) but suspicious that it has no power in the first place. Help please if you can

Re: Worcester Greenstar Heatslave 12/18 no power to control box no reset power

Posted: Sun Jul 07, 2019 2:22 pm
by ericmark
No photos, I came to look at my 18-25 and found no fewer than three fused connection units supplying it, always worth looking for simple blown fuse.

Re: Worcester Greenstar Heatslave 12/18 no power to control box no reset power

Posted: Mon Jul 08, 2019 5:27 pm
by Iceman5972
Hi Eric
Only one fuse on the pcb. I can’t reduce the pixel rate enough to allow me to include photos.
I’m not inclined to buy another Bentone dko 970 control box when it appears there is no supply to it in the first place. I’ve gone over the wiring duagram and can’t find where the supply comes from. I’ve been all over the pcb and the control box housing. I can’t source a supply in the housing for the box which makes me think it’s not the box at fault. Any thoughts please. Regards
Ian