Page 1 of 1

Unable to remove old taps

Posted: Tue Mar 10, 2009 12:40 am
by spin_32

I am having great difficulty removing a single mixer tap from my bathroom sink. This was fitted before I purchased the house so I have no idea what tools were used. My problem is that where a normal bolt should be I have instead what seems to be a flexible hard plastic something! Sorry for the poor descrition but I am unable to remove it to get at the bolt. When trying to remove the plastic cover ( I presume this is what it is) it just twists and does not create the necessary torque to turn the bolt. I have tried bending it and the plastic only moves to about half way. It looks like there is a bolt connected inside the plastic which does seem rusted and I have used Wd40 etc but with no joy.
Picture of the offending connection is hopefully below. Any help would be great as I am close to smashing the entire sink off and fitting a new one :)


Posted: Tue Mar 10, 2009 1:40 pm
by spin_32
I dont think that picture worked but check it out.. ... C00217.jpg


Posted: Tue Mar 10, 2009 3:38 pm
by mikimac
Hi, I've had a look at the picture & the plastic bolt you mention is normally a threaded rod which screws into the bottom of the mixer set. The 'half moon' plate on the underside of the sink unit is the anchor which holds the mixer unit in place & a bolt is then tightened up the rod to secure everything. I think given the amount of corrosion shown in the picture you will be lucky to get that off in one piece.