Britannia Si-9tb-ss Oven not working
Help, advice and problem solutions on all aspects of home appliances from washing machines to TV's

rdickson93
Labourer
Labourer
Posts: 1
Joined: Sat Nov 21, 2020 9:36 pm

Britannia Si-9tb-ss Oven not working

by rdickson93 » Sat Nov 21, 2020 9:42 pm

Hi all! I have an old Britannia Si-9tb-ss range cooker we got 2nd hand around 2 years ago. At first it worked fine but the larger of the 2 ovens started not to heat up correctly which i guessed was an element issue but the rest still worked fine. Recently that oven has stopped working completely, eg no heat to the elements, grill and the light stopped
working at the back. I done some googling and removed the elements to test with my multimeter to find the bottom element was faulty and so also was the themostat. I have replaced these today but oven is no different.

When I turn the oven on there is an audible fan noise coming from the above the oven (not the internal fan at the back) and you can feel the air blowing but other than that nothing else works. The elements do not heat up either on grill or any oven settings, the fan at the back does not power up and the light doesn't work inside the oven. The oven temp light which usually lights up until the oven reaches temperature does not come on at all but you can hear an audible click coming from it. Also the analogue clock has stopped working/ticking.
It is like the oven is getting no power except the small fan noise i mentioned earlier and the smaller oven still works perfectly. I'm at a loss now as I can't find anything else which could be causing the issue. I have just tested the oven thermal cut out for continuity and it seems fine. Any ideas would be appreciated. Thanks, Ross.

It is currently Mon Apr 29, 2024 12:31 am